Resolved
This issue is now resolved and full service has been restored in the area. Thank you for your patience and apologies for any disruption.
Posted .
Created
We’re currently experiencing a service outage in the Widnes area. Our Network team is already looking into it, and we’ll share an update as soon as we have more information.
We're sorry for the disruption and appreciate your patience.
Posted .
Resolved