Get in touch
Back
Maintenance

Planned Maintenance - Network Upgrades

Completed 13 Feb at 02:00am GMT.

Merseyside
Completed

Maintenance completed

Posted 13 Feb at 02:00am GMT.
Started

Our services in the following regions will undergo planned maintenance at 00:01 on 13/02/2026 to upgrade our equipment. During this time, services may be intermittently affected or unavailable.

We expect all upgrades to be completed, and full service restored, by 02:00.

We apologise for any disruption and thank you for your patience.

Sites under maintenance:
* Liverpool
* Warrington

Posted 13 Feb at 12:01am GMT.