Get in touch
Back
Resolved

Service Outage - Blackburn Area

Started 4 Feb at 09:10am GMT, resolved 4 Feb at 11:15am GMT.

Lancashire
Resolved

This issue has now been resolved. Thank you for your patience.

Posted 4 Feb at 11:15am GMT.
Created

We are currently experiencing a service outage in the Blackburn area. Our Network team is already looking into it, and we’ll share an update as soon as we have more information.

We're sorry for the disruption and appreciate your patience.

Posted 4 Feb at 09:10am GMT.