Get in touch
Back
Maintenance

Planned Maintenance - Network Upgrades

Completed 22 Jan at 04:00am GMT.

Merseyside North Yorkshire West Yorkshire
Completed

Maintenance completed

Posted 22 Jan at 04:00am GMT.
Started

Our services in the following regions will undergo planned maintenance at 00:01 on 22/01/2026 to upgrade our equipment. During this time, services may be intermittently affected or unavailable.

We expect all upgrades to be completed, and full service restored, by 4.00am.

We apologise for any disruption and thank you for your patience.

Sites under maintenance:
* Liverpool Anfield
* Liverpool Kensington
* Liverpool
* Castleford
* Saltburn

Posted 22 Jan at 12:01am GMT.