Get in touch
Back
Resolved

Service Outage: Blackburn area

Started 12 Dec at 08:44am GMT, resolved 13 Dec at 02:30pm GMT.

Lancashire
Resolved

This issue is now resolved and affected services restored. Thank you for your patience.

Posted 13 Dec at 02:30pm GMT.
Created

We are currently experiencing a service outage in the Blackburn area. Our Network team is already looking into it, and we’ll share an update as soon as we have more information.

We're sorry for the disruption and appreciate your patience.

Posted 12 Dec at 08:44am GMT.