Back
Degraded

Wentwood Drive - Keepers Gate
Started 18 Feb at 12:21pm GMT, resolved 19 Feb at 09:30am GMT.
Somerset
Resolved
Power was restored at 04:57am.
The connection is fully online.
Posted 19 Feb at 09:30am GMT.
Updated
The issue is linked to a power outage in the local area.
More information can be found below;
https://powercuts.westernpower.co.uk/incident/INCD-20106-q
Posted 18 Feb at 01:08pm GMT.

Created
We are currently aware of an issue at the Wentwood Drive - Keeper Gate development.
This is currently being investigated by our engineers.
Posted 18 Feb at 12:21pm GMT.