Get in touch
Back
Downtime

Taberner House Outage

Started 1 Dec at 09:21am GMT, resolved 1 Dec at 10:48am GMT.

London (Taberner House)
Resolved

We have now identified the issue with one of our routers at the site and the service has now been restored. We would like to say sorry to all our customer affected by the outage.

Posted 1 Dec at 10:48am GMT.
Created

We are aware of an outage at Taberner House, that started at 06:57 AM. Our engineering team is working as quickly as possible to resolve the issue. Currently, we don't have an ETA for resolution. We will provide a further update at 10AM.

Posted 1 Dec at 09:21am GMT.