Back
Degraded

Incident Affecting Multiple Locations
Started 19 Nov at 10:15pm GMT, resolved 19 Nov at 10:29pm GMT.
Core Network
Resolved
We have identified the issue, and worked with one of our partners to resolve. All services have now returned to normal, but we will continue to monitor for the next few hours.
Posted 19 Nov at 10:29pm GMT.

Created
We are currently experiencing an outage across multiple locations in the UK. Our engineers are investigating and we will provide a further update in 30 minutes.
Posted 19 Nov at 10:15pm GMT.