Get in touch
Back
Maintenance

Core Network Upgrade

Completed 22 Oct at 07:00am BST.

Core Network Manchester Core London Core Cumbria Lancashire Greater Manchester Merseyside County Durham Teeside North Yorkshire West Yorkshire East Riding Derbyshire Leicestershire Nottinghamshire Warwickshire West Midlands Glasgow Aberdeenshire East Lothian Dumfries & Galloway Perthshire Sussex Oxfordshire London (Taberner House) Cambridgeshire Gloucestershire Somerset Wiltshire
Completed

Maintenance completed

Posted 22 Oct at 07:00am BST.
Started

We are upgrading our Core Network to provide you with a more reliable service.
We anticipate a brief outage during the maintenance window, with work expected to start at around midnight (Friday Morning).

Posted 22 Oct at 12:01am BST.