Get in touch
Back
Degraded

4G back-up service

Started 6 Oct at 12:00am BST, resolved 6 Oct at 05:00am BST.

Resolved

We have identified the problem and the issue have now been resolved, and full service has been restored.

Posted 6 Oct at 05:00am BST.
Created

We are currently running on the 4G back-up service in parts of Carlisle. Customers may experience slower speeds. We're working on fixing the issues as fast as we can.

Posted 6 Oct at 12:00am BST.