Get in touch
Back
Resolved

Degraded service in Scarborough

Started 14 Feb at 05:04pm GMT.

North Yorkshire
Created

We are currently aware of customers reporting a degraded service in Scarborough, our networks team are investigating into this and will provide updates as we have them.

Posted 14 Feb at 05:04pm GMT.