Get in touch
Back
Resolved

Unexpected Issue

Started 5 Feb at 01:22am GMT.

County Durham
Created

We are currently aware of an unexpected issue which is impacting broadband service in your area.

Our Network and Engineering Teams are investigating and we will provide a further update as soon as we have more information.

Thank you for your patience while we work to identify and resolve the issue.

Many thanks,
The Grain Team

Posted 5 Feb at 01:22am GMT.