Get in touch
Back
Resolved

Northern Power Grid utility power issues affecting Sunderland South

Started 23 Dec at 08:00pm GMT.

Tyne and Wear
Created

We are experiencing issues with the Northern Power Grid utility power in Sunderland South area, NPG are working on this INCD-474553-A with a ETR of 02:00. Cabinets are running on backup power and generators are currently on route.

Posted 23 Dec at 08:00pm GMT.