Back
Degraded

Service Degraded: Cumbria
Started 28 Mar at 07:49pm BST, resolved 29 Mar at 03:47am BST.
Cumbria
Resolved
Our partner resolved the issue at 03:47 today following repairs after a fibre strike. Normal service in Cumbria has now been restored.
Posted 29 Mar at 03:47am BST.

Created
We are currently aware of an issue affecting the network in the Cumbria region which will result in slower than normal download speeds due to an outage with one of our partners. We are working with them to resolve the issue and will provide an update as soon as we know more.
Posted 28 Mar at 07:49pm BST.