Get in touch
Back
Degraded

Xbox - Packet Loss

Started 15 Feb at 09:53pm GMT, resolved 16 Feb at 09:04am GMT.

Core Network
Resolved

The issue with Xbox Packet Loss now seems to be resolved. If you are still experiencing issues help please drop us an email.

Posted 16 Feb at 09:04am GMT.
Created

We are seeing multiple reports of packet loss affecting Xbox gameplay. We have confirmed that other broadband providers are experiencing similar issues and we believe the issues is related to the Xbox network. We are monitoring the situation and will update when we know more.

Posted 15 Feb at 09:53pm GMT.